更新

git のインストール (CentOS 6)

Certbot クライアント(旧・Let's Encrypt クライアント)のダウンロードには、バージョン管理システムの git が必要です。

標準インストールした CentOS 6 や Red Hat Enterprise Linux 6 (RHEL 6) には git が含まれていないため、パッケージ管理システム yum を使ってインストールする必要があります。

※CentOS 6.7 の DVD ISO (CentOS-6.7-x86_64-bin-DVD1.iso) には git は含まれていません。

エラーメッセージ

git がインストールされていない場合、Certbot クライアントのダウンロード時に、下記のエラーメッセージが表示されます。

実行するコマンド:
$ git clone https://github.com/certbot/certbot
コマンド実行後に表示されるエラーメッセージ:
bash: git: コマンドが見つかりません

解決策

パッケージ管理システム yum を使って git をインストールします。

実行するコマンド:
$ sudo yum install git
コマンド実行後に表示されるメッセージの例:
読み込んだプラグイン:fastestmirror, refresh-packagekit, security インストール処理の設定をしています Loading mirror speeds from cached hostfile * base: ftp.iij.ad.jp * extras: ftp.iij.ad.jp * updates: ftp.iij.ad.jp 依存性の解決をしています --> トランザクションの確認を実行しています。 ---> Package git.x86_64 0:1.7.1-4.el6_7.1 will be インストール --> 依存性の処理をしています: perl-Git = 1.7.1-4.el6_7.1 のパッケージ: git-1.7.1-4.el6_7.1.x86_64 --> 依存性の処理をしています: perl(Git) のパッケージ: git-1.7.1-4.el6_7.1.x86_64 --> 依存性の処理をしています: perl(Error) のパッケージ: git-1.7.1-4.el6_7.1.x86_64 --> トランザクションの確認を実行しています。 ---> Package perl-Error.noarch 1:0.17015-4.el6 will be インストール ---> Package perl-Git.noarch 0:1.7.1-4.el6_7.1 will be インストール --> 依存性解決を終了しました。 依存性を解決しました ================================================================================ パッケージ アーキテクチャ バージョン リポジトリー 容量 ================================================================================ インストールしています: git x86_64 1.7.1-4.el6_7.1 updates 4.6 M 依存性関連でのインストールをします。: perl-Error noarch 1:0.17015-4.el6 base 29 k perl-Git noarch 1.7.1-4.el6_7.1 updates 28 k トランザクションの要約 ================================================================================ インストール 3 パッケージ 総ダウンロード容量: 4.7 M インストール済み容量: 15 M これでいいですか? [y/N]y パッケージをダウンロードしています: (1/3): git-1.7.1-4.el6_7.1.x86_64.rpm | 4.6 MB 00:01 (2/3): perl-Error-0.17015-4.el6.noarch.rpm | 29 kB 00:00 (3/3): perl-Git-1.7.1-4.el6_7.1.noarch.rpm | 28 kB 00:00 -------------------------------------------------------------------------------- 合計 693 kB/s | 4.7 MB 00:06 rpm_check_debug を実行しています トランザクションのテストを実行しています トランザクションのテストを成功しました トランザクションを実行しています インストールしています : 1:perl-Error-0.17015-4.el6.noarch 1/3 インストールしています : git-1.7.1-4.el6_7.1.x86_64 2/3 インストールしています : perl-Git-1.7.1-4.el6_7.1.noarch 3/3 Verifying : perl-Git-1.7.1-4.el6_7.1.noarch 1/3 Verifying : 1:perl-Error-0.17015-4.el6.noarch 2/3 Verifying : git-1.7.1-4.el6_7.1.x86_64 3/3 インストール: git.x86_64 0:1.7.1-4.el6_7.1 依存性関連をインストールしました: perl-Error.noarch 1:0.17015-4.el6 perl-Git.noarch 0:1.7.1-4.el6_7.1 完了しました!

以上で、git のインストールは完了です。

Certbot クライアントの準備 の手順で、Certbot クライアントをダウンロードしてください。

スポンサーリンク
Menu
ページトップへ